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Bulk Import Spreadsheet - Bulk Add or Edit Users (Not for HR Integration)

Instructions on using our bulk import sheet to import, export, or edit your user list and each user's profile.
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ARTICLE DETAIL

BULK UPLOAD/ BULK IMPORT SPREADSHEET  -  ADD, EDIT, OR

IMPORT USER DATA INTO THE RELIAS LMS

________________________________________________________________________

 

The Relias Platform provides an option to handle a mass import or mass export of multiple/all users

via an excel spreadsheet.  The following information will explain how to handle the importing and

exporting processes.

 

Please click here to download and print the spreadsheet   

(https://relias.my.salesforce.com/sfc/p/d0000000fdHa/a/0V000000x0VR/YsMjbdyWWQzEhpDa

SpGxq2s7DVXgGzbImRuLFRsDXEo)

You may encounter a dark screen that says "Preview Not Available" 

Click "Download" at the top of the screen
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Exporting Users

 

To obtain a hard copy of your user list you will want to use the Export User function. 

 

1. As an Administrator, click the Users tab.

2. You can filter the user list by a number of different options:

a. Alphabetically by last name

b. Active, Inactive, or All

c. Any other available filter option you would like to use

3. After selecting any applicable filters, click the Export Users link.  Clicking this link prompts an

Excel spreadsheet download.  After opening the download in Excel you can print or edit the

spreadsheet.
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Exporting the user list from your site is helpful if you need to edit multiple Learner accounts at one

time. 

 

Please Note: The export file looks very similar to the Bulk Import spreadsheet; however, the export

file and the Bulk Import spreadsheet are not the same. 

The export file includes additional columns that are not present on the Bulk Import

spreadsheet. Because of this, the export file cannot be used to import users, but you can carefully

copy and paste the data from some fields into the Import data. 

Always use caution when copying and pasting data from the export file into the Bulk Upload

spreadsheet. Thank you! 

 

 

Importing Users

While it is possible to add or edit users manually (Add and remove users

(https://connect.relias.com/s/article/DOC-1652) ), it may not be the most convenient option if you

need to add or edit a large number of Learners at one time.  In this scenario, it is better to use the

Bulk Import function and utilize the Bulk Import spreadsheet.

After opening up the Bulk Upload spreadsheet, refer to the User Profile Field Definitions tab in the

spreadsheet for a detailed outline of each column's requirements.

https://connect.relias.com/s/article/DOC-1652
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The Bulk Import Spreadsheet (a.k.a. Import User, User Data, or 

Bulk Load Spreadsheet)

 

You will find a link to download the Bulk Import spreadsheet both at the top and bottom of this

knowledge article. 

 

Please Note: The spreadsheet contains macros.  Your computer may warn you that macros can

contain computer viruses.  While this is true, and you should always maintain proper virus protection

on your computer, the macros in the Bulk Load spreadsheet are supposed to be there and will not

cause any problems for your computer.  

Confirm that the sheet opens with the macros prompt, or that a message displays below the top

menu that macros are enabled (in excel 2007 and later, make sure you enable macros).

 

 

 

Import User Formatting Requirements

 

 Each column must be formatted correctly according to the instructions on the spreadsheet (check

the bottom tabs on the spreadsheet for additional sheets containing important information about

format and data requirements: Instructions, User Profile Definitions, Examples, Data and Roles) 

 

There are only 4 required profile fields that must be filled in on the spreadsheet before it can be

uploaded: Last Name, First Name, Username, and Password.  

If you need to review the user profile to see which fields are recommended or necessary for your

organization, you may wish to review the Add & Remove Users Article

(https://connect.relias.com/s/article/DOC-1652) . 

 That article will explain each field in more detail.  

 

Email address is also a required field for anyone with the Administrator, Supervisor, Instructor, Data

https://connect.relias.com/s/article/DOC-1652
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Entry, or Observer permission.  

 

While only 4-5 fields are required, we strongly recommend that as many fields as possible be filled in

so you can take full advantage of the features that the Relias LMS has to offer. 

 

 

Quality Assurance Checklist and Techniques

 

Before you import the file, please check for the following items, which tend to be common errors:

1. Typos – Check all columns for typos, but especially in the Report Filter and Hire Date columns

(e.g., misspelled report filter values, incorrect dates).  For example, if job title Admin Assistant is

accidentally misspelled for one user (Admin Assistant), then both values will be uploaded creating

a duplicate job title in the system.

2. Blanks – Confirm that no blanks exist in the four required columns (first name, last name,

username, and password) and that any blanks in other columns are intentional.

3. Duplicate Usernames or Learner IDs – Check to make sure there are no duplicate user names. This

is the identifier of each person on your user list and it must be unique.  If you have more than one

user with identical usernames (e.g., Jennifer Smith and John Smith both have user name of jsmith),

only one will be uploaded.  If you have populated the Learner ID column, make sure there are no

duplicates.  Learner IDs must be unique if you want to upload historical training data.  See the end

of this page for methods to check duplicates.

4. Existing Users Entered With A New Username - A username is considered the unique identifier of

a user. Adding a new username to an existing user will not update the username. Rather, this

will create a brand new profile for that user. The user will then have 2 active profiles after the

successful upload of your spreadsheet.    How can this field be updated? - Update the username in

your Relias LMS first, a few hours PRIOR to doing your bulk upload. Once the user profile in the

LMS reflects the updated name, you can add the updated name to the Relias bulk upload template

and have it processed. The update on the spreadsheet should recognize the update on the LMS

site and will validate the change. 

5. Format – Make sure your employee data is on the Data tab and not the Examples tab or any other

tab.  The first row of users should appear on line 4; any information on lines 1-3 will not be

uploaded.  If you have hidden any rows or columns, make sure you unhide them before

submitting/uploading the spreadsheet.  You must use the excel spreadsheet provided in this

article for the import to be successful.

6. Email addresses -  If you have included emails, make sure each user has a unique email address.  If

a user does not have an email address, leave it blank and do not use another user's email. Confirm

that all users are identified as Supervisors, Administrators, DataEntry, Observers, or Instructors

have a valid, complete email address.  Any user role other than Learner must have an email
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address.  All emails must be complete and valid; any typos or omissions will prevent a successful

import.  Common mistakes include: leaving off the .com or .org, misspelling, nothing after the @

symbol, comma instead of period, etc.

Check for Invalid Email Addresses - A formula you can use to verify the email address is: 

=IF(LEN(L4)>0,ISERR(SEARCH("@",L4)+SEARCH(".",RIGHT(L4,5))+ISERR(SEARCH("

",L4))))=FALSE. Copy and paste the formula in a blank column, starting on row 4 (in the

formula, L4 refers to the email address cell) and then copy and paste it all the way down the

column as far as you have data.  The results will either be TRUE or FALSE and the ones that say

FALSE are email addresses that require modification.  The formula checks for the @ symbol, a

period in the final five characters and no spaces.  This is not going to check every possible typo,

but it will help considerably.

7. Format: Column Definitions Tab – Review the column definitions tab to view the required format

of information in each cell.  If you used formulas in excel to populate fields like email, username,

password, etc., you must remove the formula from the sheet and put the values/actual data in the

cells instead.  The upload will not work if formulas are in any field on the sheet.

8. Count Users – Count how many users you will upload on the sheet.  Then, check how many users

are in the site by going to Users and viewing the Active User count.  After completing the upload,

go to Users > User Management and make sure the total number of users in the site is correct.  If

there are a few missing, recheck the bulk load.  Usually, the most common mistake is duplicate

usernames.  Additionally, make sure you are not exceeding your contracted number of users.  If

you need to modify your contract to allow for more users, please contact Relias Support, or reach

out to your CSM or Account Manager. 

9. Users Assigned to Hierarchy Folders – Make sure each user is assigned to a Hierarchy folder.  To

obtain the Hierarchy ID, please see Creating and Editing the Hierarchy

(https://connect.relias.com/s/article/DOC-1984).  Each hierarchy folder can only contain one

warning email recipient, so please confirm that column AA has only one X for each hierarchy

folder.

10. User Category – This feature is typically used for assigning training plans to users in bulk;

however, it also can act as a report filter in some reports.  You must separate multiple User

Categories for a user with a semi-colon. 

11. Check for Typos and Blanks – Use auto filter to easily scan through the values contained in a

column without having to view every instance of the values.  You can also see the blanks in a

column and confirm all blanks are intentional.

12. Fields that Override If Left Blank- There are 6 fields which will override if left blank on the bulk

spreadsheet, but at the same time have existing data entered in the same field in your RLMS

training site. These fields are:  Department, Job Title, Location, Employment Type, and User

Category, and Instructor Credentials. Read the article User Profile Customization

(https://connect.relias.com/s/article/DOC-1615) for details on those fields. 

https://connect.relias.com/s/article/DOC-1984
https://connect.relias.com/s/article/DOC-1615
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13. Check Duplicate Values – In excel 2007 and later, highlight the column you want to check for

duplicate values.  On the Home tab, go to Conditional Formatting > Highlight Cell Rules >

Duplicate values.  Every value in the row that has a duplicate will be highlighted and you can

easily find and modify them.

14. Macros Enabled – Confirm that the sheet opens with the macros prompt or displays below the top

menu that macros are enabled (in excel 2007 and later, make sure you enable macros).

15. Reformat before Creating .xml – The spreadsheet needs to be reformatted to upload successfully,

the instructions on how to do this are on the first tab of the spreadsheet attached.

16. Required Fields - If you have designated any fields as "Required Fields

(https://connect.relias.com/s/article/DOC-1616) " in your Relias training site, but those fields are

left blank when uploading new users, your results may come back with errors unless these fields

are filled in.  

 

 

Saving The Spreadsheet

Once you have entered in your data and followed the QA process, follow the instructions for saving

and testing the Bulk Upload Spreadsheet

1. Make sure macros are enabled and the data is correct.

2. From the menu bar in your excel sheet, Select File -> Save As. A message will appear asking

whether or not you would like to create the XML at this time. Select NO. 

3. Continue with naming your bulk file and then store in a folder on your device where it can be

easily identified and retrieved. 

4. From the menu bar in your excel sheet, Select File -> Save. A message will appear asking whether

or not you would like to create the XML at this time. Select YES. 

5. This will allow the Bulk file to be saved in XML format, which is now compatible to upload in to the

Relias Platform. The file will automatically be saved with the same name and in the same folder as

the file you previously created. 

6. After you save the spreadsheet in XML format, you can upload the XML file to the Relias database

in your Relias training site. Log in to your training site as an Administrator > go to Users> User List

on the left navigation bar.   

7. Click the Import Users link. 

https://connect.relias.com/s/article/DOC-1616
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8.  Choose File/Browse (this depends on your browser).  Locate the .txt or .xml file on your

computer and click open

9.  It is important to make sure the checkbox is selected for the  "only validate file" option  to verify

that the import will be successful, but will not officially upload the information. This will simply

trigger a scan it to ensure that there are no major issues or exceptions that need to be corrected

 

 

 

10. Click Upload.

11. If you are validating the file, the system will advise you if the file is likely to be successful or if any

errors are found.

 

If the file has any errors, you will see a message similar to this one. You can then select the

"Download Results File" button to download a file that will include your data with additional

columns "Result" (Success/Failed)" and "Result Message" that gives the reason the result failed.
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 If the file has no major exceptions or errors, you will see this message.  

Please Note: this does not necessarily mean that your file is perfect or is not missing information, it

merely means that there are no major errors that would prevent the file from importing. 

 

 

12.  If you want to continue with truly importing your data,  select Choose File/Browse again to select

the same .txt or .xml file. 

13. To upload the data and override your current data, uncheck the "Only validate file" option.

 

  14. Click Upload.  Once the file is uploaded, the system will let you know if the import

was successful.  

 

IMPORTANT!    Once you have successfully imported your user

data, please wait 90-minutes before attempting to export the data.

Accuracy on exported user data cannot be guaranteed any earlier

than the 90-minute threshold.                                          
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Privacy Statement

 

To begin your bulk upload, please  Click Here to Download the Bulk Upload Spreadsheet

(https://relias.my.salesforce.com/sfc/p/d0000000fdHa/a/0V000000x0VR/YsMjbdyWWQzEhpDa

SpGxq2s7DVXgGzbImRuLFRsDXEo) 

 

**Relias employees Only - For further help with the Bulk Upload, see this internal article **

(https://relias.lightning.force.com/lightning/r/Knowledge__kav/kA00V000001d4OC/view)

https://relias.my.salesforce.com/sfc/p/d0000000fdHa/a/0V000000x0VR/YsMjbdyWWQzEhpDaSpGxq2s7DVXgGzbImRuLFRsDXEo
https://relias.lightning.force.com/lightning/r/Knowledge__kav/kA00V000001d4OC/view

